x86 platform drivers · Maintained
Maintainers
- M Hans de Goede <hansg@kernel.org>
- M Ilpo Järvinen <ilpo.jarvinen@linux.intel.com>
Paths
- F
drivers/platform/olpc/ - F
drivers/platform/x86/ - F
include/linux/platform_data/x86/
Last 30 days
Recent patches
Most-recent 30 patches in this subsystem on linux-wireless (capped at 30), ordered by date desc.
-
STALE216d
[PATCH RFC RESEND 8/8] thermal: core: Allow setting the parent device of thermal zone devices
2025-11-20 · Armin Wolf <W_Armin@gmx.de> -
STALE216d
[PATCH RFC RESEND 6/8] thermal: core: Set parent device in thermal_cooling_device_register()
2025-11-20 · Armin Wolf <W_Armin@gmx.de> -
STALE752d
[PATCH v1 1/1] treewide: Align match_string() with sysfs_match_string()
2024-06-03 · Andy Shevchenko <andriy.shevchenko@linux.intel.com> -
STALE936d
REVIEWED: 6 (6M) [PATCH v16 2/9] platform/x86/amd: Add support for AMD ACPI based Wifi band RFI mitigation feature
2023-12-11 · Ma Jun <hidden> -
STALE940d
REVIEWED: 6 (6M) [PATCH v15 2/9] platform/x86/amd: Add support for AMD ACPI based Wifi band RFI mitigation feature
2023-12-06 · Ma Jun <hidden> -
STALE941d
[PATCH v14 2/9] platform/x86/amd: Add support for AMD ACPI based Wifi band RFI mitigation feature
2023-11-29 · Ma Jun <hidden> -
STALE955d
[Patch v13 2/9] platform/x86/amd: Add support for AMD ACPI based Wifi band RFI mitigation feature
2023-10-30 · Ma Jun <hidden> -
STALE955d
[PATCH v12 2/9] platform/x86/amd: Add support for AMD ACPI based Wifi band RFI mitigation feature
2023-10-17 · Ma Jun <hidden> -
STALE1030d
REVIEWED: 18 (18M) [PATCH AUTOSEL 6.4 39/41] Fix nomenclature for USB and PCI wireless devices
2023-09-08 · Sasha Levin <sashal@kernel.org> -
STALE1025d
REVIEWED: 18 (18M) [PATCH AUTOSEL 6.5 43/45] Fix nomenclature for USB and PCI wireless devices
2023-09-08 · Sasha Levin <sashal@kernel.org> -
STALE1202d
REVIEWED: 10 (10M) [PATCH V6 06/15] platform/x86: serial-multi-instantiate: Replace all spi->chip_select and spi->cs_gpiod references with function call
2023-03-10 · Amit Kumar Mahapatra <hidden> -
STALE1209d
REVIEWED: 10 (10M) [PATCH V5 06/15] platform/x86: serial-multi-instantiate: Replace all spi->chip_select and spi->cs_gpiod references with function call
2023-03-06 · Amit Kumar Mahapatra <hidden> -
STALE1210d
REVIEWED: 10 (10M) [PATCH v4 06/15] platform/x86: serial-multi-instantiate: Replace all spi->chip_select and spi->cs_gpiod references with function call
2023-02-10 · Amit Kumar Mahapatra <hidden> -
STALE1241d
REVIEWED: 10 (10M) [PATCH v3 06/13] platform/x86: serial-multi-instantiate: Replace all spi->chip_select and spi->cs_gpiod references with function call
2023-02-02 · Amit Kumar Mahapatra <hidden> -
STALE1249d
[PATCH v2 07/13] platform/x86: serial-multi-instantiate: Replace all spi->chip_select and spi->cs_gpiod references with function call
2023-01-19 · Amit Kumar Mahapatra <hidden> -
STALE1437d
[PATCH] platform/x86: pmc_atom: Add DMI quirk for Lex 3I380A/CW boards
2022-07-27 · Matwey V. Kornilov <hidden> -
STALE1384d
LANDED [RFC PATCH] genirq: Provide generic_handle_domain_irq_safe().
2022-05-09 · Sebastian Andrzej Siewior <bigeasy@linutronix.de> -
STALE1469d
[PATCH v2 01/14] thermal/core: Change thermal_zone_ops to thermal_sensor_ops
2022-05-07 · Daniel Lezcano <hidden> -
STALE1544d
[PATCH] drivers: Fix spelling mistake "writting" -> "writing"
2022-04-08 · <hidden> -
STALE1585d
LANDED [PATCH 5/5] spi: make remove callback a void function
2022-01-23 · Uwe Kleine-König <hidden> -
STALE1808d
LANDED: 47 (47M) [PATCH v4 5/5] bus: Make remove callback return void
2021-07-13 · Uwe Kleine-König <hidden> -
STALE1817d
REVIEWED: 47 (47M) [PATCH v3 5/5] bus: Make remove callback return void
2021-07-13 · Uwe Kleine-König <hidden> -
STALE1815d
REVIEWED: 45 (45M) [PATCH v2 4/4] bus: Make remove callback return void
2021-07-06 · Uwe Kleine-König <hidden> -
STALE1822d
[PATCH] bus: Make remove callback return void
2021-07-06 · Uwe Kleine-König <hidden> -
STALE1795d
LANDED [PATCH] firmware: replace HOTPLUG with UEVENT in FW_ACTION defines
2021-04-25 · Shawn Guo <hidden> -
STALE2083d
LANDED [RFC] treewide: cleanup unreachable breaks
2020-10-17 · trix@redhat.com -
STALE2192d
LANDED: 2 (1M) [PATCH v7 11/11] thermal: Rename set_mode() to change_mode()
2020-06-29 · Andrzej Pietrasiewicz <hidden> -
STALE2192d
LANDED: 2 (1M) [PATCH v7 10/11] thermal: Simplify or eliminate unnecessary set_mode() methods
2020-06-29 · Andrzej Pietrasiewicz <hidden> -
STALE2192d
LANDED: 1 (1M) [PATCH v7 07/11] thermal: Use mode helpers in drivers
2020-06-29 · Andrzej Pietrasiewicz <hidden> -
STALE2192d
LANDED [PATCH v7 08/11] thermal: Explicitly enable non-changing thermal zone devices
2020-06-29 · Andrzej Pietrasiewicz <hidden>